7 7
Melodiction

Ouverture du Wiki.

Recommended Posts

Je bataille sur le fichier .htaccess, c'est normal que vous n'y ayez plus accès :P

J'ai bousillé deux skins. Youhouuuu, jamais deux sans trois j'le sens venir !

 

Voilà contre quoi je me bats : 

 

RewriteEngine On

RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^wiki/(.*)$ wiki/index.php?title=$1 [PT,L,QSA]
RewriteRule ^wiki/*$ wiki/index.php [L,QSA]
RewriteRule ^wiki$ wiki/index.php [L,QSA]

Partager ce message


Lien à poster
Partager sur d’autres sites

Question bête mais tu as désactiver l'ancien wiki pour pas avoir de conflit de règle sur les url? :')

 

D’après http://meta.wikimedia.org/wiki/Talk:Eliminating_index.php_from_the_url

Les règles ressemble a sa
 

RewriteEngine onRewriteBase /RewriteCond %{REQUEST_URI} !^/(stylesheets|images)/RewriteCond %{REQUEST_URI} !^/(redirect|texvc|index).phpRewriteRule ^(.*)$ /index.php?title=$1 [L,QSA]

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai désactivé l'ancien oui. Et en fait, le gros soucis que j'ai, c'est qu'à chaque tentative de fail, les "liens symboliques" meurent derrière (je ne sais pas trop où j'avoue) et les fichiers CSS ne se chargent plus...

Partager ce message


Lien à poster
Partager sur d’autres sites

Partager ce message


Lien à poster
Partager sur d’autres sites

J'vois pas le rapport avec le .htaccess du forum.

 

Je pense que mon .htaccess est bon maintenant. J'utilise celui à la racine ROOT comme indiqué sur les tutos. En revanche, le LocalSettings de MediaWiki doit être foireux.

 

En fait, j'ai fait la connerie d'installer le wiki dans /wiki et c'est la pire des choses à faire. Ils recommandent d'installer sur /w pour ensuite pouvoir toucher les URL et mettre /wiki dedans. Le fait d'avoir les deux noms identiques a tout fait foirer.

 

J'ai changé le dossier du wiki en /w mais j'suis pas sûr que ce soit suffisant.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tous les skins fonctionnent sauf le principal, vector. Je ne sais absolument pas pourquoi le lien stylesheet est foireux, ni d'où ça vient, étant donné que tous les autres skins fonctionnent. J'ai essayé de remettre à jour les fichiers du skin au cas où l'un d'entre eux aurait été corrompu, et cela n'a rien changé.

 

Je pense qu'il doit y avoir un "cache" quelque part dans la BDD qui a été écrit à un moment donné et que le site ré-utilise sans cesse malgré qu'il soit corrompu.

Partager ce message


Lien à poster
Partager sur d’autres sites

Plop, ça marche de mon coté aussi.

 

je serai bien chaud pour aider mais j'aimerai le faire en compagnie de quelqu'un, je trouve ça plus convivial et mon faible niveau d'orthographe m'interdit toute forme d’écriture compréhensive.

 

l'idée serai de ce mettre a deux (ou plus) derrière un pc, choisir un thème et laisser aller.

 

Des gens motivés sur Toulouse?

Partager ce message


Lien à poster
Partager sur d’autres sites
7 7